Partial Service Disruption in EU Environment

Minor incident EU Environment API (EU Environment) Application/UI (EU Environment)
2026-05-05 20:48 IDT · 2 hours, 30 minutes

Updates

Resolved

The issue has been resolved, and all services are now operating normally.
A detailed RCA will be provided soon.

May 5, 2026 · 23:18 IDT
Issue

We are currently experiencing a service disruption affecting our EU environment.

What’s impacted:

  • Custom Dashboards are temporarily unavailable
  • Some filtering capabilities on the Violations page may be slower than usual

Current status:
Our team has identified the issue and is actively working to restore full functionality. All data remains safe.

Next update:
We will continue to share updates as we make progress.

May 5, 2026 · 20:48 IDT

← Back