Service Availability Issue

Minor incident US Environment API (US Environment) Application/UI (US Environment)
2025-11-10 14:40 IST · 18 hours, 33 minutes

Updates

Resolved

US region API timeouts were traced to CPU saturation in our feature-flag service. We increased capacity by raising CPU/memory requests and limits, scaling replicas, and increasing the liveness-probe timeout. We also lengthened client polling to reduce load.
Service is stable. we’re adding metrics and tracing to prevent recurrence.

November 11, 2025 · 09:13 IST
Monitoring

We’ve mitigated the issue and increased resources to prevent further impact. The service is stable, and we’re continuing to monitor while investigating the root cause.

November 10, 2025 · 17:44 IST
Issue

We are investigating the issue.

November 10, 2025 · 14:40 IST

← Back