PR Scans are Delayed

Minor incident US Environment API (US Environment) Application/UI (US Environment)
2025-06-30 18:37 IDT · 4 hours, 23 minutes

Updates

Resolved

The issue is now resolved.

June 30, 2025 · 23:00 IDT
Update

PR scans that don’t involve custom policies or CI/CD security now work as expected. It’s important to note that a ‘FAILURE’ status on the Cycode UI’s PR scans page doesn’t mean the PR itself will fail in your SCM. We’re actively working to improve this flow

June 30, 2025 · 22:20 IDT
Update

We are actively working to resolve an issue with CI/CD security, SCA, and license scans.

June 30, 2025 · 21:24 IDT
Monitoring

Description: We’re currently investigating an issue affecting the synchronization of Pull Requests from GitHub to our platform. As a result, we’ve experienced delays and missed updates in the syncing of certain pull request statuses, particularly those created overnight.
This issue has been reported by multiple users who observed that their pull request statuses were not immediately updated on our platform.

Impact:

  • Open pull requests may not appear with their most current status on our platform.
  • Your actual code repositories on GitHub remain untouched and fully functional; the issue is with how our system processes and displays the pull request status.

Next Steps: Our engineering team is treating this as a critical incident and is actively working to identify the root cause of these synchronization issues. To ensure all delayed pull requests are updated, we’ve initiated a comprehensive sync of all open pull requests. We are gathering more data to accelerate our investigation and resolution. We’ll provide updates as soon as we have more information or a full resolution.

June 30, 2025 · 18:37 IDT

← Back