User Login Failures Due to Misconfiguration

Minor incident EU Environment API (EU Environment) Application/UI (EU Environment) US Environment API (US Environment) Application/UI (US Environment)
2025-06-30 12:45 IDT · 1 hour, 2 minutes

Updates

Post-mortem

Summary:

On June 30, 2025, users experienced login failures when attempting to sign in. The issue resulted in an infinite login loop and affected multiple users across different environments.
The root cause was a misconfiguration in the authentication setup, which caused the login system to reject requests with unauthorized responses. This prevented users from completing the login process.

Timeline:

06.30.25 12:45 PM (GMT+3) – Users reported being stuck in an infinite login loop when signing in.
06.30.25 12:48 PM (GMT+3) – The issue was escalated for immediate investigation.
06.30.25 12:49 PM (GMT+3) – Engineering team assigned and began working on resolution.
06.30.25 01:43 PM (GMT+3) – The problem was identified as a configuration issue affecting authentication. The misconfiguration was corrected, and normal login functionality was restored.
06.30.25 01:47 PM (GMT+3) – Further analysis revealed inconsistencies in how configuration settings were applied across environments, leading to the error.

Root Cause Analysis:

A misconfigured authentication setup led to authorization failures for login requests. This misconfiguration stemmed from inconsistent application of settings across environments. As a result, the login system could not properly validate user sessions, triggering a loop in the login process.

Actions Taken:

  • Identified and corrected the incorrect configuration setting.
  • Synchronized configuration values across all affected environments.

Action items:

  • Add synthetic monitoring for login flow – Simulate user logins to detect issues like login loops or failed redirects before they affect users
  • Add additional measures to our configuration management module to help avoid misconfigurations
June 30, 2025 · 15:10 IDT
Issue

This incident has been resolved.

June 30, 2025 · 15:07 IDT

← Back