Slowness and Incorrect Data on Inventory, Discovery and Reports Pages

Minor incident US Environment API (US Environment) Application/UI (US Environment)
2025-04-15 15:05 IDT · 4 days, 6 hours, 30 minutes, 1 second

Updates

Resolved

We experienced a brief period of slowness and incorrect data on the Inventory, Discovery, and Reports pages. The issue was identified and addressed in collaboration with our database vendor, who applied configuration changes to improve system performance.

While the exact root cause is still under investigation, current evidence points to long-running queries—potentially related to reports or data exports—as a contributing factor. Since the changes were implemented, we’ve been closely monitoring the system and have not seen a recurrence of the issue. Based on this, we are confident the issue is mitigated and are closing the incident.

We kept the incident open for an extended period to allow for thorough monitoring. Although it’s now resolved, we’ll continue our investigation with the database vendor to identify the root cause. Once we have a clear RCA (Root Cause Analysis), we’ll share it accordingly.

We appreciate your patience and understanding.

April 19, 2025 · 21:32 IDT
Monitoring

We are monitoring the load of the database.

April 15, 2025 · 22:19 IDT
Issue

Users are experiencing slow load times and inaccurate data on the Inventory and Discovery pages. The team is investigating the issue to identify the root cause and implement a fix.

April 15, 2025 · 15:05 IDT

← Back