Increased 503/504 Errors on Violations Page

Minor incident EU Environment API (EU Environment) Application/UI (EU Environment)
2025-04-02 16:50 IDT · 2 hours, 53 minutes

Updates

Resolved

The issue causing increased 503/504 errors on the Violations page has been resolved. The root cause was a high load on our database due to a large volume of CLI scans from a specific customer. We mitigated the issue by blocking the source IP and implementing rate limits to prevent similar occurrences.

We will continue monitoring the system to ensure stability. A full RCA will be provided soon.

Thank you for your patience.

April 2, 2025 · 19:42 IDT
Monitoring

We have identified the root cause of the increased 503/504 errors on the Violations page. The issue stems from a high load on our database due to a large volume of CLI scans from a specific customer.

To mitigate the immediate impact, we are working on blocking the source IP. Additionally, we are implementing rate limiting and other safeguards to prevent similar issues in the future.

We will continue monitoring the situation and provide further updates. A full RCA will be shared once the incident is fully resolved.

Thank you for your patience.

April 2, 2025 · 17:58 IDT
Issue

We are currently experiencing increased 503/504 errors on the Violations page, affecting both the API and UI. The issue has been identified as high database load caused by a recent migration. Our team is actively working on resolving this.

We will provide updates as we make progress and share a full RCA at the end of the incident.

Thank you for your patience.

April 2, 2025 · 16:50 IDT

← Back