[US] Performance Degradation in Violations Page and Related Sections

Minor incident US Environment API (US Environment) Application/UI (US Environment)
2024-03-17 23:31 IST · 3 days, 19 minutes, 1 second

Updates

Resolved

This incident has been resolved.

March 20, 2024 · 23:50 IST
Monitoring

A fix has been implemented and we are monitoring the results.

March 18, 2024 · 19:01 IST
Investigating

We are currently investigating reports of slower-than-usual performance on our platform, specifically on the violations page and pages displaying violation counts. Users may experience delayed response times or prolonged loading periods when accessing these areas.

Our engineering team is actively working to identify the root cause of the slowdown and implement a fix.
We are prioritizing this as a high-impact issue and are dedicating resources to resolve it as quickly as possible.

March 17, 2024 · 23:31 IST

← Back