Resolved
MemoryDB metrics are stable, the processing lag has recovered, and the system is now fully operational.
Monitoring
We observed a sharp spike in MemoryDB memory utilization in prod-us, including active swap usage.
Mitigation has been applied. MemoryDB metrics have remained stable since then, and the processing lag is decreasing quickly
Investigating
We have noticed degraded performance in prod-us
Flows like Pull Request or CLI scanning can be slower than usual