Root Cause
The incident was caused by a deployment of one service that ran a database migration. The team has identified that this migration contained faulty code and as a result lead to database overload when attempting to deploy the service. As a result, the service was partially down until the deployment was reverted. During this time, all scans were processed with lower than expected performance.
Resolved
Root Cause
The incident was caused by a deployment of one service that ran a database migration. The team has identified that this migration contained faulty code and as a result lead to database overload when attempting to deploy the service. As a result, the service was partially down until the deployment was reverted. During this time, all scans were processed with lower than expected performance.
Resolved
The system is now back to being fully operational.
Monitoring
The team has identified the root cause and resolved it. We are seeing the system getting back to stability.
Investigating
The team identified an issue with degraded performance with scanning. There can be delays in starting, running, and completing scans. All scan types may be affected (Pull request and CLI scans as well).
The team has identified an issue with a malfunction in deployment, and the issue should be resolved shortly.