Resolved
AWS has confirmed that the issue has been fully mitigated and we are currently not observing any related issues.
Monitoring
We are starting to see stabilization and a reduction in API errors. However, we continue to closely monitor the situation.
Monitoring
Mitigation: We temporarily scaled up the managed node group to get pods scheduled while we wait for AWS to fully resolve the underlying issue.
Investigating
Please refer to the AWS Health Status page for details on the related incident: https://health.aws.amazon.com/health/status
Investigating
We are experiencing delays in infrastructure provisioning caused by cloud provider API rate limiting. We are actively investigating the issue with our cloud provider.