Summary
On June 10, 2026, customers may have experienced intermittent issues with their GitHub integrations due to an external authentication incident on GitHub's side. This resulted in some integrations temporarily reporting invalid access tokens and a brief pause in repository syncing and scanning. The issue was resolved once the external provider restored their authentication services. All integrations have automatically returned to normal operation, and no customer action is required.
Key Timeline (IDT)
June 10, 2026, 18:20 IDT: The external provider began experiencing authentication issues affecting API requests.
June 10, 2026, 18:20 IDT: Our processing system began receiving intermittent unauthorized responses, leading to temporary integration errors and paused syncing.
June 10, 2026, 19:39 IDT: The external provider identified and mitigated the faulty component, resolving the incident.
June 10, 2026, 19:39 IDT: Integrations automatically re-validated, and expected processing behavior was restored.
Root Cause
The incident was caused by an external authentication failure at GitHub. During this window, the provider's API erroneously returned "Unauthorized" responses for a portion of traffic. Our system interpreted these responses as revoked access tokens, which triggered temporary integration error states and paused background workflows.
Actions Taken
Monitored the external incident status and its impact on our integration workflows.
Verified that integrations automatically recovered and resumed syncing once the external provider restored service.
Confirmed that no manual re-authentication was necessary for affected customers.
Action Items
Improve internal handling of intermittent authentication errors to better distinguish between temporary external outages and actual token revocations.
Enhance monitoring to more quickly identify when third-party service disruptions impact integration health.
Resolved
Summary
On June 10, 2026, customers may have experienced intermittent issues with their GitHub integrations due to an external authentication incident on GitHub's side. This resulted in some integrations temporarily reporting invalid access tokens and a brief pause in repository syncing and scanning. The issue was resolved once the external provider restored their authentication services. All integrations have automatically returned to normal operation, and no customer action is required.
Key Timeline (IDT)
June 10, 2026, 18:20 IDT: The external provider began experiencing authentication issues affecting API requests.
June 10, 2026, 18:20 IDT: Our processing system began receiving intermittent unauthorized responses, leading to temporary integration errors and paused syncing.
June 10, 2026, 19:39 IDT: The external provider identified and mitigated the faulty component, resolving the incident.
June 10, 2026, 19:39 IDT: Integrations automatically re-validated, and expected processing behavior was restored.
Root Cause
The incident was caused by an external authentication failure at GitHub. During this window, the provider's API erroneously returned "Unauthorized" responses for a portion of traffic. Our system interpreted these responses as revoked access tokens, which triggered temporary integration error states and paused background workflows.
Actions Taken
Monitored the external incident status and its impact on our integration workflows.
Verified that integrations automatically recovered and resumed syncing once the external provider restored service.
Confirmed that no manual re-authentication was necessary for affected customers.
Action Items
Improve internal handling of intermittent authentication errors to better distinguish between temporary external outages and actual token revocations.
Enhance monitoring to more quickly identify when third-party service disruptions impact integration health.
Monitoring
GitHub experienced an authentication incident starting at 15:10 UTC, which is still ongoing. This caused intermittent API authentication failures for our services.
https://www.githubstatus.com/incidents/fcj3088jg1wx
This issue can affect all Cycode interactions with GitHub, including PR scans.
Some of our GitHub refresh token API returns Unauthorized responses, resulting in valid integration being incorrectly marked as invalid. Impacted installations showed errors such as "Token was revoked" or "Token owner no longer belongs to the organization"—these are false positives due to the GitHub issue, and the tokens were not actually revoked.
No customer action is needed regarding tokens or credentials. All affected installations are expected to automatically recover once the GitHub issue is resolved.
We are continuing to monitor the situation and will provide further updates if additional action is required.