Summary
On June 10, 2026, customers may have experienced slowness in SAST Pull Request scanning. The root cause has been identified in insufficient processing capacity in one of the services used in SAST Pull Request scans flow. This resulted in degraded performance and a portion of scans taking longer time than usual to start and to complete. The processing capacity has since been increased and adequate alerts have been created to ensure the issue does not occur again.
Key Timeline (IDT)
June 10, 2026, 17:50 IDT: Performance degradation began.
June 10, 2026, 18:15 IDT: The team noticed degraded performance and began working on stabilizing the system.
June 10, 2026, 18:40 IDT: The system was confirmed to be fully operational.
Root Cause
The incident was caused by an insufficient processing capacity in one of the services involved in SAST Pull Request scan flow. This means, that under heavy load, the service struggled to maintain its operational velocity. The team also found that the SAST Pull Request scans flow was not fully optimized and it lead to over-utilization of the service.
Actions Taken
Increased processing capacity of the bottleneck service.
Created alert to detect bottlenecks quicker.
Optimized behavior of the service.
Action Items
Further optimize SAST Pull Request scanning flow.
Resolved
Summary
On June 10, 2026, customers may have experienced slowness in SAST Pull Request scanning. The root cause has been identified in insufficient processing capacity in one of the services used in SAST Pull Request scans flow. This resulted in degraded performance and a portion of scans taking longer time than usual to start and to complete. The processing capacity has since been increased and adequate alerts have been created to ensure the issue does not occur again.
Key Timeline (IDT)
June 10, 2026, 17:50 IDT: Performance degradation began.
June 10, 2026, 18:15 IDT: The team noticed degraded performance and began working on stabilizing the system.
June 10, 2026, 18:40 IDT: The system was confirmed to be fully operational.
Root Cause
The incident was caused by an insufficient processing capacity in one of the services involved in SAST Pull Request scan flow. This means, that under heavy load, the service struggled to maintain its operational velocity. The team also found that the SAST Pull Request scans flow was not fully optimized and it lead to over-utilization of the service.
Actions Taken
Increased processing capacity of the bottleneck service.
Created alert to detect bottlenecks quicker.
Optimized behavior of the service.
Action Items
Further optimize SAST Pull Request scanning flow.
Resolved
The system is now fully stable
Identified
We have noticed degraded performance in SAST PR scans