Summary
On May 8, 2026, a temporary issue within our internal processing system interrupted the routine renewal of GitLab access credentials for a subset of integrations. This caused affected integrations to stop syncing and appear as disconnected. Because the affected credentials were no longer valid, they could not be restored from our end — each affected integration had to be manually re-authenticated by the customer in order to resume syncing. No customer data was lost or exposed, and no credential security was compromised.
Key Timeline (UTC)
May 8, 2026, 21:10 UTC: A temporary slowdown in the database processing system began affecting credential updates.
May 8, 2026, 21:40 UTC: The system identified that a subset of GitLab integrations were unable to complete their routine credential renewals.
May 8, 2026, 22:30 UTC: The root cause was identified as a failure to save newly issued credentials during the renewal process.
May 8, 2026, 23:30 UTC: Corrective measures were implemented to stabilize the update workflow and prevent further integrations from being affected.
May 9, 2026, 00:40 UTC: The affected integrations were identified, and impacted customers were notified that re-authentication was required to restore them.
Root Cause
The issue was triggered by a temporary interruption in our internal update process. During a routine renewal of access credentials, a brief disruption in the processing system prevented the newly issued credentials from being saved successfully. Because the previous credentials were automatically retired by GitLab as part of the standard security workflow — the moment the new credentials were issued — the affected integrations were left without a valid credential. As the credential was no longer valid and could not be recovered from our end, these integrations could not be restored automatically and required the customer to re-authenticate.
Actions Taken
Stabilized the internal update workflow to prevent further integrations from being affected.
Identified the affected integrations and notified the impacted customers that re-authentication was required.
All affected customers re-authenticated their integrations, fully restoring normal syncing.
Verified that all previously synced data remained intact and secure.
Action Items
Improve monitoring to detect similar processing issues in the update workflow more quickly.
Make credential renewal resilient so a newly issued credential is reliably saved as part of the same operation, and so any save failure is detected immediately — eliminating the window where a renewed credential can be lost and an integration is left unrecoverable.
Optimize the processing system to better handle temporary fluctuations in activity.
Resolved
Summary
On May 8, 2026, a temporary issue within our internal processing system interrupted the routine renewal of GitLab access credentials for a subset of integrations. This caused affected integrations to stop syncing and appear as disconnected. Because the affected credentials were no longer valid, they could not be restored from our end — each affected integration had to be manually re-authenticated by the customer in order to resume syncing. No customer data was lost or exposed, and no credential security was compromised.
Key Timeline (UTC)
May 8, 2026, 21:10 UTC: A temporary slowdown in the database processing system began affecting credential updates.
May 8, 2026, 21:40 UTC: The system identified that a subset of GitLab integrations were unable to complete their routine credential renewals.
May 8, 2026, 22:30 UTC: The root cause was identified as a failure to save newly issued credentials during the renewal process.
May 8, 2026, 23:30 UTC: Corrective measures were implemented to stabilize the update workflow and prevent further integrations from being affected.
May 9, 2026, 00:40 UTC: The affected integrations were identified, and impacted customers were notified that re-authentication was required to restore them.
Root Cause
The issue was triggered by a temporary interruption in our internal update process. During a routine renewal of access credentials, a brief disruption in the processing system prevented the newly issued credentials from being saved successfully. Because the previous credentials were automatically retired by GitLab as part of the standard security workflow — the moment the new credentials were issued — the affected integrations were left without a valid credential. As the credential was no longer valid and could not be recovered from our end, these integrations could not be restored automatically and required the customer to re-authenticate.
Actions Taken
Stabilized the internal update workflow to prevent further integrations from being affected.
Identified the affected integrations and notified the impacted customers that re-authentication was required.
All affected customers re-authenticated their integrations, fully restoring normal syncing.
Verified that all previously synced data remained intact and secure.
Action Items
Improve monitoring to detect similar processing issues in the update workflow more quickly.
Make credential renewal resilient so a newly issued credential is reliably saved as part of the same operation, and so any save failure is detected immediately — eliminating the window where a renewed credential can be lost and an integration is left unrecoverable.
Optimize the processing system to better handle temporary fluctuations in activity.
Investigating
We identified an issue that caused some GitLab integrations to become invalid between 8 May, 20:00 and 9 May, 01:00. Affected integrations need to be reconnected to resume working.
We are working with our infrastructure provider to investigate the root cause and to put safeguards in place to prevent this from happening again.
We will share an update as soon as we have more information.
We have identified the affected customers and will be reaching out to them directly with next steps. If you have not been contacted, your integration is not affected.