Resolved
A fix supporting both the old and new formats was deployed at 13:00 IST.
Monitoring
GitLab recently changed the time format in some of their webhooks, which caused our webhook processing to fail starting at 00:00 IST. As a result, some webhook events were not processed successfully.